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Basic Concepts 

Opening, Creating, and Saving a Project 
 

TerraExplorer basic commands are available from the TerraExplorer button located at the upper-left corner of the 
application. 
 
Opening an Existing Project  

Click  and then click Open > browse to an existing .Fly file. 
You can open a US demo project by clicking the link on the Start 
page. 

Saving a Project as a FLY File  

A .Fly file is a compressed binary file that contains all the project 
settings and content, and pointers to terrain databases (MPT) or 
other loaded files.  

Click  and then click Save or Save As… 

Creating a New Project  

Click  and then click New > In dialog, browse to required terrain database (MPT), and click OK > Define project settings. 

 
 

Navigating in the 3D Window 
 

Navigate through the 3D World in the way you find most natural and intuitive: navigate freely using on-screen 
Navigation controls or any of the three mouse modes, or fly to predefined locations or objects. 
 

Viewing or Flying to a Location or Object (Using the Project Tree)  

1. In the Project Tree, double-click the location or object, or right-click and select Fly to, Jump to, or View. If you view the object, 
you can select one of the pre-defined flight patterns that compass about the object.  

2. To stop a flight to a location right-click in 3D Window, and select Stop or press the Spacebar. 

Free Flight  

Using the mouse to navigate 

  Navigation tab > > click a Navigation mode to determine how the mouse controls navigation. In Drag mode , do the 
following: 

  To pan – Click and drag the mouse to the sides, forward, or backward.  

  To zoom in and out – Roll the middle mouse wheel. 

  To change direction and tilt – Click and drag the middle mouse wheel. 

Using HUD Navigation Controls: 

1. View tab > select Graphic HUD to display.  

To change plane tilt - Click and drag tilt slider.  To look North - Click North 
indicator.  

To free fly in all directions- Use blue joystick. To zoom in and out – Click 
and drag zoom slider.   

To change plane direction - Click and drag 
compass ring. 

To slide right, left, forward or 
back- Click corresponding arrows. 

Underground Navigation  

1. Home tab > Underground Mode.  

2. Navigate in the 3D environment. You can freely go through the terrain surface in any direction. 

Following a Dynamic Object  

 In the Project Tree > double-click the required dynamic object. 
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Basic Concepts 

Managing Projects—Using the Project Tree 
 

The Project Tree provides a list of elements in the terrain that can be sorted and arranged into groups. Using this list, 
you control the appearance of information in the 3D Window. 
 

Showing and Hiding Objects or Layers in the 3D Window 

In Project Tree, click the object or layer’s show/ hide icon  to display or hide it in 
the 3D Window. 

Selecting a Tree Item  

In Project Tree, click the item. Double–clicking performs the item’s activation 
action (fly to, jump to, circle/ oval/ line pattern, etc.) that was set in its property 
sheet. 

Creating and Working with 

Groups  

1. Right-click blank area (root) of 
    Project Tree (for subgroup, right-
     click parent group) > select Create 
     Group.  

2. Type the name of the new group 
    and press ENTER. 

3. To move an item into a new 
     group, click and drag it onto 
     group folder. 

4. To add a new element to a group, 
    right-click group > point to New >     select Location, Presentation or     Message. 

5. To set group properties, right click <group> > Properties. In property sheet, set 
                                                                                 parameters. 

Creating Locations  

1. In the Project Tree right-click > New > Location. Type a name for the location and click. 

2. Open property sheet to set activation action or add a message: in Project Tree right-click location > Properties. 

  

System Requirements 
 

System requirements for installing and using TerraExplorer. 
 
 

 Operating System - Windows® XP/ Vista/ 7. 

 System Memory – 1GB of RAM (4 GB or more recommended). 

 Video Card - 128MB of video memory (512 MB or more recommended). Pixel and vertex shader v3.0 is required for dynamic 
water effects, animated cloud map, and sky texture. 

 Processor – Pentium IV or equivalent. 

 Internet Connection - Broadband connection (recommended). 

 Browser - Microsoft Internet Explorer 7 or higher. 
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Project Settings 

Basic Project Settings 
 

Project Settings, including general settings, terrain parameters, flight model, and application layout are saved in the .Fly 
file and applied each time this file is used. 
 

To open Settings dialog: Home tab > click Project Settings > Click required tab. 

Environment tab 

 Select a Sky Color and Fog Color. 

 Enter a Visual Range (largest visible distance to the horizon). 

 Select Sky texture and Clouds map to apply. Select Clouds speed and if to enable water effects. 

Terrain Database tab 

 Select the local or remote Terrain (MPT) Database currently used by this project. 

 Enter the Number of Terrain Imaginary (resolution) Levels that are used to enhance the visual quality when the camera is 
close to the ground. 

 Set the project’s Terrain Coordinate System. 

Date and Light tab 

 Control the sun display and the startup date and time. 

 Select the Use Sunlight check box if you want the sun to serve as the light source for the project.  

 Select a range and Date and Time for the Startup Time Slider.  

General tab 

 Set basic parameters for the .Fly file, including startup message parameters.  

 Click Set as Home to set the current camera location as the default startup position for 
this .Fly file.  

 Click Add Message to determine the message to be shown when the project is opened.  

 Click Wait to set the number of seconds TerraExplorer waits at the beginning of the 
session.  

 
 

Controlling Date and Time 
 

When the sun is used as a project’s light source, displayed light on the terrain corresponds to the date/ time selected on 
the Time Slider. Project data containing timespan tags displays on the terrain according to the timespan set. 

 

1. View tab > select Time Slider. The Time Slider displays in the 3D Window. Drag 

the blue marker and yellow arrow  together to the required date and time 
on the slider. If you want to display data whose timespans fall anywhere in a 
time range, drag the blue marker to the start point of the time range and the 

yellow arrow to the endpoint of the time range . 

2. Click Date and Time Settings  icon to the right of the slider to select a time 
zone, and time slider range. (When a one year range is selected, two sliders display, one for the date, and one for the time of 
day).  

Note: Project startup settings for the date and time can be set in the Date and Light tab in the Project Settings dialog box and 

are saved in the .Fly file. Any date and time settings made using the Date and Time Settings  icon are not saved to 
the .Fly. 
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Tools 

Measurement and Terrain Analysis Tools 
 

TerraExplorer measurement and terrain analysis tools deliver extensive topographical and strategic information, 
enabling a more accurate geospatial understanding of the terrain. 
 

Measurement and Line of Sight Tools 

Analysis tab > click required tool:  

Horizontal/ Aerial/ Vertical Distance 

 Click any point in the terrain or on an object to define the start point and 
other segments. Right-click to finish. 

 

 

Terrain Area (and Perimeter)  

  Click to define start point. Drag to additional points and click to define a 
region. Right-click to finish. > In open dialog select either: 

 Horizontal Plane (for horizontal projection).  

 Terrain Surface (for surface area)> enter Sample interval> click 
Calculate. 

 
 

3D Plane Area and Perimeter (of a polygon on an arbitrary plane)  

  Click to define start point. Drag to additional points and click to define a 
region. Right-click to finish.  

 

  

 

Line of Sight - Indicates whether specific locations in the 3D World can be 
seen (green line) from a selected position or not (red). 

  In property Sheet, set parameters > In 3D Window, click to define observer 
viewpoint, then click additional times for targets. Right click to finish.  

 

Viewshed - Indicates which areas on the entire selected terrain are visible 
from the viewpoint (colored in green), and which areas cannot be viewed 
(red). 

  In property Sheet, set parameters > In 3D Window, click to define observer 
viewpoint, then click for endpoint.   

 
 

Threat Dome - Indicates the volume visible from a given point on the terrain. 

   In property Sheet, set parameters > In 3D Window, click to define pivot 
point. 
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Analysis Tools 

Analysis tab > click required tool:  

 

Slope Map - Apply palette colors according to degree of slope and slope 
arrows to indicate slope direction. 

1. Select Slope Colors/ Slope Arrows. 

2. In property sheet, set parameters such as palette and coverage area, 

3. Click in 3D Window to add opposite corners of the coverage rectangle. 

 
 

 

Contour Map - Apply palette colors to each elevation level and connect points 
of equal elevation with contour lines. 

1. Select Contour Colors/ Contour Lines. 

2. In property sheet, set parameters such as contour palette and coverage 
area. 

3. Click in 3D Window to add opposite corners of the coverage rectangle. 

 

 

 

 

Flood Tool - Calculate land covered by flooding. 

1. In 3D Window, click center of coverage area. 

2. In property sheet, set single instance of water level rising or continuous 
and related parameters. 

3. Drag mouse to required radius size and click. 

 

 

 

 

Volume Tool - Analyze amount of terrain removed from or added to the 
terrain surface.  

1. Objects tab > click Modify Terrain > Draw a polygon in the 3D Window to 
define the terrain area for which you want to modify elevation values. 

2. On Analysis tab click Volume Tool. In dialog box select checkboxes of 
objects to analyze and click Calculate. 

 

 

 

Best Path - Calculate best path without exceeding definable climb and 
descent slope limits. 

   In property Sheet, set parameters > In 3D Window, click to define start and 
end point. 

 

 
 

Best Path 

Volume Tool 

Flood Tool 

Contour Map 

Slope Map 
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Presentations 

Creating and Editing a Presentation 
 

Easily share your 3D visualization with others by creating a multi-step presentation that can be replayed, in which you 
combine a customized flight route with a particular display of the project. 
 

Step 1: Create a flight route – Animate movement over the terrain by 

recording your navigation or by adding locations 

Creating a Recorded Route 

1. Presentation tab> Record Flight.  

2. Navigate freely in the 3D Window to any location or point of interest. Adjust zoom, tilt, 
etc.  

3. Presentation tab> Stop Record.     

Creating a Locations Route 

Fly to the required location, and then Presentation tab> Add Location   OR    

Presentation tab> Add Location > Select Location. Select a location from the list 
of project locations.  

Step 2: Animate what is displayed on the terrain 

Add presentation steps to: 

  Determine what is visible on the terrain and in the 3D Window – Show or Hide: objects, groups, TE 
tools, and messages. 

  Animate data through time - Visualize time-based data over time, so that you can see a pattern or 
trend emerge (e.g. flood progression or city growth). You can also set the Presentation time or 
Adjust Time Slider Range to Group to affect the visibility of objects and groups with timespan tags. 

  Change the speed of the presentation steps or launch a different presentation from the current 
one. 

In Presentation Editor, right-click step > click Add Operation > select an operation.  

Step 3: Edit the presentation   

1. Presentation tab> Edit Presentation. 

2. Add captions when required: right-click step> 
Add Caption. 

3. Use Move Up and Move Down commands to 
reorder steps. 

4. To delete a step, select it and click Delete.  
5. For each step, select mode for advancing the 

step: Continue trigger > 

 Immediate - Next step follows immediately. 

 Click Button – Next step follows when Next 

command on the Ribbon is clicked. 

Step 4: View Presentation  

Click Presentation tab > Play.  Use the toolbar to start, stop, pause, rewind, and fast forward.   

Creating Movies 
 

Share your 3D visualization even with people who do not have TerraExplorer installed, by creating a movie in AVI 
format from any presentation in your project. Your movie can then be shown using any standard AVI Viewer. 

 

1. Create a presentation. 

 

1. Presentation tab > Movie group > set frame size and number of frames per second. 

2. Presentation tab > Movie group >Create Movie. 

3. Browse to location for movie file. 

4. Set Video Compression properties. 
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Working with Objects 

Basic Objects 
 

Add and edit graphic entities, each with its own styling properties. Objects include: labels, lines, polygons, 2D/ 3D shapes, 3D 
models, and buildings. Available objects depend on TerraExplorer level. Objects can be organized in Project Tree groups. 
 

Creating an Object  

1. Objects tab> click <required object>.  

2. Click and draw the object in the 3D Window. Right-click to finish. For 2D and 3D shapes, left-click to finish. 

Selecting an Object 

After selecting a single object, a yellow frame surrounds the object and the object’s property sheet opens. When selecting 
multiple objects, a yellow frame surrounds each of the selected objects and the Multi Edit property sheet opens. 

Selecting a Single Object  

 From Project Tree: In the Project Tree, select the object > On the Home tab, click Properties. OR 

 From 3D Window: On the Home tab, click Select> In the 3D Window, select the object.  

Selecting Multiple Objects  

 From Project Tree: In the Project Tree, select the required objects (Use SHIFT and CTRL to select sequential and non-sequential 
tree items) > On the Home tab, click Properties. 

 From 3D Window: On the Home tab, click Select > Press and hold the CTRL key > In the 3D Window, select each of the objects 
you want > On the Home tab, click Properties.  

 From 3D Window (all objects in a selected area): On the Home tab, click Select Area > In the 3D Window, draw the area 
polygon by clicking the mouse (at least three points) and right-click to finish > On the Home tab, click Properties. 

Editing an Object 

1. Project Tree > Right-click object and select Properties. On the top of the property sheet, click: 

  To edit the entire object. Then: 

 To move object. Then drag to required location. 

 To change the object’s altitude. Then drag to required height. 

 To edit object nodes, click .  Then:  

Note: Only polylines, 2D polygons, and 3D polygons (added in TE Plus or Pro) 
have object nodes.  

  to move a node. Then 
click required node and drag to new location.  

  to change node’s altitude. Then click required node and drag to new 
height. 

 To delete a node, point to the node, right-click, and select Delete. 

 To add a node, point to one of the object’s lines, and click anywhere a red 
node appears. 

Note: Object position and nodes can also be modified from object’s property 
sheet. 

2. Set properties such as color, altitude, timespan, tooltip, and texture in the object’s 
property sheet. 

Adding 3D Models  

1. Objects tab > click 3D Model.  

2. In dialog, browse to the required file to load.  

3. In 3D Window, click mouse to define position of model’s pivot point on terrain. 

4. Adjust the model’s position and size in the 3D Window or from property sheet. See: “Editing an 
Object.”  

5. Using the property sheet, set the parameters of the 3D object.  

6. Drag any of the three arrow resizers in/ out to adjust any of the model’s dimensions. 
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Advanced Objects 
 

Create advanced objects: dynamic objects, modify terrain objects, video, buildings, and 3D models. 
 
 

 Creating and Editing Dynamic Objects 

1. Objects tab> Video, 3D Objects, or Dynamic Objects group> click <required object >. 

2. Property sheet > File Name field > browse for a model file. 

3. In the property sheet, set Motion Style and other properties. 

4. In 3D Window, click mouse to define waypoints. Right-click to finish. 

5. For editing, see: “Editing an Object.” Note that object nodes correspond to object’s route waypoints. 

Creating Buildings 

1. Objects tab > click Building. 

2. In 3D Window, click the mouse to define roof polygon. Right-click to finish. 

3. If there is no horizontal offset between roof and base, right click to finish. If there is an offset, drag base to place and left-click.  
4. In property sheet, set building’s properties including height, texture, and roof style. 

Video on Terrain and Video Billboard 

Play a video file on an area of the terrain or on a floating billboard. 

1. Objects tab > Video on Terrain/ Video Billboard. 

2. Browse to a video file. For a streaming video, click Cancel, and in property sheet, 
type the URL. 

3. Set location of video:  

 In property sheet, set Use Telemetry File to Yes, and browse to file 

 In property sheet, set Use Telemetry File to Yes, and in 3D Window, click to 
define location. 

4. In property sheet, set projector properties and other video parameters. 

5. To play, pause, and stop video, right-click in Project Tree and select required option. 

 

Multi-Resolution City Model – Make XPL 
 

Creates a set of files where each file contains data for one Level of Detail (LOD). TerraExplorer dynamically loads and 
displays the LOD file based on the viewer position in relation to the object, improving performance and download rate. 
 
1. Tools tab > click Make XPL.  

2. Browse to required Source directory and Output directory. 

3. Select the required settings, including the following:  

 To save all the textures of each of the model’s faces in a 
single file, select Merge textures to a single texture. 

 To create LOD files for model geometry in addition to 
textures, select Create multi-resolution models. 

4. To create a single XPL file for multiple models (good for 
small models) > a. Select the Enable grouping check box. 
Then browse to the required Shape input file and select a 
File name attribute. 

b. In the Output shape file type a path to a file that will 
store new models’ coordinates. 

c. Select required check boxes. 

d. Select a Maximum group size. TerraExplorer will create an XPL file that groups the maximum number of models together in 
each area without exceeding the designated group size. 

5. Click Go.  
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Working with Raster Layers 

Loading Raster Layers 
 

Raster layers include imagery layers containing geo-referenced, satellite or aerial images that overlay the terrain 
imagery, and elevation layers containing geo-referenced elevation raster that replaces the elevation data of the terrain. 

 

1. Home tab > click Raster Layer > select Elevation/ Imagery Layer from file or from server. 

2. In the dialog, browse to the required file, and click Open. 

3. If loading from server, select the required server, and click Select. 
In the dialog that displays, enter the information required for the 
selected server, and select the required layer. 

Note: If the source file is geo-referenced it is positioned 
accordingly on the terrain. Otherwise, it is placed at 
the center of the 3D Window. You can then manually 
edit its position, or reproject it. 

4. If the source file does not include coordinate system information 
or TerraExplorer cannot read it from the file, the Coordinate 
System dialog box opens. Specify the coordinate system of the 
layer.  TerraExplorer then reprojects (converts) the layer data to 
the project’s coordinate system. Although the source file retains 
its original coordinate system, it is placed on the terrain 
according to the reprojection parameters.  

5. After the object has been placed on the terrain, you can change its 
properties using the property sheet. To clip a subsection of the 
raster, click the Draw button in the Imagery/ Elevation section of the property sheet. Place at least three polygon points in 
the 3D Window by clicking in the desired location. Finish by right-clicking. 

 

Creating Resolution Pyramids 
 

To enable the display of a layer at different altitudes, TerraExplorer requires a number of resolution levels per layer, 
also known as a resolution pyramid. If a layer does not have sufficient resolution levels, TerraExplorer can create them. 

 

 1. In Project Tree, select layers that require a resolution pyramid. 

2. Tools tab > click Resolution Pyramid. 

3. In dialog, select layers, and click Create Pyramid. 
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Working with Feature Layers 

Loading Feature Layers 
 

A feature layer is a visual representation of a geographic data set using geographic features such as points, lines, and 
polygons. In contrast to objects, all the features in a layer share the same properties and behavior. These properties can 
be modified from the layer’s property sheet. 
 

1. Home tab > click Feature layer. 

2. If loading from file, in dialog, browse to required file and 
click Open.  

3. If loading from server, select the server type, and click 
Connect. Fill in the required Connection parameters for 
the specific server or database, and click Connect.  

4. Select a layer from the Select Layer dialog box and click 
Next. 

5. Set the layer’s General Settings. Then click Next.  

a. If the layer’s coordinate system is different from the 
terrain’s, select the Reproject check box. Then click 
the Set Coordinate System button to open the 
Coordinate System dialog page to specify the 
coordinate system of the layer.  

b. Select Stream to retrieve layer information 
dynamically based on the camera’s position. Select 
Entire Layer to load the entire layer when the .Fly file 
opens.  

c. Select the Annotation Symbol check box to 
automatically add a point annotation object in the 
center of each layer feature.  

d. In the Predefined Visibility section, select the viewer altitude from which visibility distance and scale is set to optimum.  

5. Select the attribute fields to load. In the property sheet, set layer parameters, and apply different properties such as line color 
or cylinder height, based on the attribute field values of the objects.  

 

Feature Layer Operations 
 

Spatial operations on a layer’s features include: merging features into a single feature, clipping one polygon from 
another, exploding a multi-part feature into its individual component features, and exporting selected features to a 
new file. Feature layer operations are only enabled for TerraExplorer Pro users. 
 

                  

Selecting Features (Individual Selection or by Spatial Query) 

1. In Project Tree, select required layer. 

2. Select the individual features required: 

a. Layer Edit tab > click Select Feature. 

b. In the 3D Window, select the required feature. To select multiple features, press and hold the CTRL key.     OR  

3. Select features based on their spatial relationship with a polygon, line or point you draw, or with an existing object: 

a. Layer Edit tab > click Spatial Query. Select Area (polygon), Line, Point or Object. 

b. In the Type dropdown list >select Intersect to select all features whose geometry intersects at any point with the selection 
geometry. Select Completely Within to select only features whose entire geometry falls within the selection geometry.  

c. In the Buffer dropdown list >enter a buffer radius outside the selection.  

d. In the 3D Window, click to draw a polygon, line or point or select the required object for feature selection. 

 

Layer Edit 
tab on 
ribbon 
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Using the Attribute Table: Searching for Features and Editing Feature Attributes 

1. In Project Tree, select required layer. Then Layer Edit tab > Attribute Table. 

2. In the Query builder section, enter an attribute, condition, and value and click Insert 
    String.  

3. If you want to include additional strings in your search expression, click one of the 

    connector buttons: and repeat step 2 for the next condition. Then click 
    Search.  

4. To display on the terrain only filtered features, click Operation button > select Show 
    Exclusive.  

5. To create a new layer of filtered features, click Operation button > Add as new layer 
    entry. 

6. To save the selected features to a new .Shp or .Fly file, click Operation button > select 
    Save As. 

7. To modify attribute properties, double-click the attribute value and modify as required.  

Exporting Selected Features to a New File 

1. Select the required features. See: “Select Features.”   

2. Layer Edit tab > click Export Layer >select Save Selected Features As.  

3. In dialog, type a File name. Browse to the required Save location and click Save. 

Adding a Feature to a Layer 

1. Select the layer. Then Layer Edit tab > click Add [Polyline, Point, or Polygon].  

2. In property sheet, set the parameters of the geographic feature. In 3D Window, place the object’s points by clicking in the 
desired location. Right-click to finish.  

Editing Features (Merge, Clip, Intersection, Explode) 

1. Select required features (Merge: Only polylines/ polygons, Intersection, Clipping: Only 
polygons).  

2. On the Layer Edit tab > click Editing and select one of the following: 

  To merge features into one feature: select Merge > in 3D Window, click feature whose 
attributes should be used for merged object. 

  To clip: select Clip > in the 3D Window, click the polygon to clip from the other 
polygons. 

 To create a new feature from intersection of features: select Intersection > in the 3D 
Window, click the polygon that should determine the attributes.  

  To explode a multi-part feature into component features: Layer Edit tab > click Editing > To explode all features: select 
Explode All. To separate out only specific features: select Explode. Then, in 3D Window, select features that you want to 
separate out. 

Saving a Layer 

 On the Layer Edit tab, click Save Layer to save changes to original layer.  

 Click Export Layer > Save As to save to a new file.   
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TerraCatalog 

Working with TerraCatalog 
 

TerraCatalog is a catalog database that enables you to easily locate geographic data and load it into a TerraExplorer 
Project. When a project is bound to TerraCatalog, any modifications to this layer within the TE project update the catalog. 
 

Connecting to a Catalog 

1. Home tab> click Connect to Catalog.  

2. In dialog, browse to Connection file, and type User name and Password. Click Connect. 

Searching the Catalog 

1. Home tab> Search Catalog. Select the 
layer type you want to search for. 

2. To search according to geographic 
location, in dialog: 

a. Select Use bounding box, and then 
select a geographic region by: 
selecting from drop-down, typing its 
coordinates, or selecting it on map.   

b. Select Intersect to search for any 
sources that intersect with defined 
region. 

c. Select Contain or Cross by to search 

only for sources that are entirely 
contained within defined region, or 
whose border intersects with 
region’s border.  

d. Click Search. 

3. To search by query, in dialog:  

a. Click Query builder button.  

b. Enter attribute, condition, and value and click Insert String. 

c. Click Search. 

Loading a Layer from Catalog 

Search > In dialog, select required layer and click Open. 

Viewing and Modifying Layer Information 

Search > In dialog, select required layer and click Properties. 

Importing Sources into Catalog 

1. Home tab > click Catalog Manager. 

2. On Manager page > Click Load. 

3. On Load page, browse for required file or folder, enter required information, and click Load. 
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Collaboration 

Collaborating over the Network with Other TerraExplorer Users 
 

Connecting over the internet/intranet, multiple users can work together in the 3D environment: chat, annotate the 
terrain with text labels and free hand drawing, synchronize flight, and share content by dragging any object/layer to a 
shared folder. One user serves as the manager of the session, while the rest connect to the session as clients. 
 

The collaboration server can run on a local computer of one of the session members, or as part of an existing TerraGate server 
(to enable better management and control and to solve security problems when accessing end-user computers behind 
firewalls).  

When a collaboration server is activated, using the Start Local Session request, it serves the current session on a local machine 
and after the termination of the session the server shuts down. When the collaboration server is set up as part of the TerraGate 
server it is always up and running. 

Joining or Opening a Session  

1. Tools tab > click Collaboration.  

2. Select a connection type: 

 Local session—To start a communication server on your local computer, and serve as manager and leader of the session.  

 New session on server—To create a new session on a TerraGate server of which you are the manager and leader. Then type 
the Server host name (name or IP address of the server). 

 Join session—To join an ongoing session opened by another user on a local computer or on a TerraGate server. Then type 
the Server host name (name or IP address of the Manager’s local computer or the TerraGate server). 

3. In the Choose Session Name field, type the session’s name. If you join an ongoing session, type the session name that was 
given by the manager. 

4. In the Choose User Name field, type a user name.  

5. If you started a local or a server session, from the On User Connection drop-down list, select whether to send the Fly project 
or link to users who join the session. 

6. Click the Start Session button to create the session or Join Session to join an ongoing session. A second Collaboration dialog 
box opens. 

Managing a Session 

If you created the session: 

 To appoint a different leader, in Participants list, select name >click Set as 
Leader.  

 To send your camera position to other participants, select Broadcast location. 

If you joined a session: 

 To attach your 3D Window to leader’s view, select Follow leader check box. 
Clear to navigate freely. 

 To invite participants to session, click Invite button. Then in the Enter Email(s) 
field, type the e-mail address. Click Invite. Follow the instructions in the 
message body and send the mail.  

Collaborating with Other Session Participants 

You can chat, point, draw freehand, add and place text labels, and share content with other participants in the session. 

Loading .Fly and KML/ KMZ Files 
 

When another TerraExplorer project (.Fly layer) or KML/KMZ file is loaded in TerraExplorer, the geographic content is 
read and put in the Project Tree as a group. 

 

1. Home tab > click Feature layer > select .fly or kml/ kmz.   

2. In dialog, browse to required file and click Open.   
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Publishing 

Creating Projects for Distribution—Publishing TerraExplorer Kits 
 

The Publish TerraExplorer Kit process collects all the files that are used in the project and stores them in the target 
directory. 
 

1. Save project. 

2. Home tab> click Publish > select one of the following: Local 
Kit/ Internet Kit/ Extract and Publish as Offline Kit. 

3. In the dialog that opens, in the Kit Folder field, enter or 
browse for the name of the folder that is to contain the kit 
files. 

4. For Local Kit:  

a. In the Terrain database field, select whether to copy the 
terrain database to kit, to keep a link to database, or not 
copy (to save space). 

b. Select the Include TerraExplorer install kit check box for 
user who doesn’t have TE installed > Click OK. 

5. For Internet Kit: Enter the address for uploading the header file and data. 

6. For Extract and Publish Area as Offline Kit (Create a directory for           
    offline use that contains the terrain, layers, objects, and resources of a 
    selected subset of the TerraExplorer project).  

a. In the Properties section of dialog, click Set Polygon and mark area  
        of interest by drawing a clip polygon in 3D Window. 

b. When updating existing offline kit, if want to accelerate process by      
         skipping terrain and layer extraction for existing files, select relevant         

                                                                                                       check boxes.> Click Publish. 
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